• Hello Guest!

    We have recently updated our Site Policies regarding the use of Non Commercial content within Paid Content posts. Please read the new policy here.

    An offical announcement about this new policy can be read on our Discord.

    ~The VaMHub Moderation Team
  • Hello Guest!

    We posted an announcment regarding upcoming changes to Paid Content submissions.

    Please see this thread for more information.

Naturalis (free)

Plugins Naturalis (free) v1.2.4 (53.var)

everlaster

Well-known member
Featured Contributor
Messages
420
Reactions
2,569
Points
93
Website
patreon.com
Twitter
everlasterVR
Patreon
everlaster
everlaster submitted a new resource:

Naturalis (free) - Natural behavior for breasts & butt. Automatic, dynamic adjustments and full customization.

Want to share something or need help? Join my Discord: https://discord.gg/2h8PgczkeW

Naturalis v1.0

A short adult fairy tale (Cinematic trailer)


Naturalis combines TittyMagic and BootyMagic into a single package. TittyMagic comes with many improvements compared to the latest standalone...

Read more about this resource...
 
If I remove TittyMagic from addon folder will the scenes automaticlly update to Naturalis?
 
If I remove TittyMagic from addon folder will the scenes automaticlly update to Naturalis?
No, you should keep the latest standalone TittyMagic var package installed. You can then use the AutoUpgrade.cs script to upgrade from TittyMagic 5 to Naturalis in a given scene. Details on that here: https://everlastervr.github.io/docs/naturalis/v1_0/auto_upgrading/#about-upgrading-from-tittymagic-5

In theory that could've been made to work on scene load automatically, but it's better if it's left to the user. For one thing, the names of triggerable parameters are different in the plugins, so loading Naturalis in place of TittyMagic will break any triggers in the scene that target the plugin's parameters.
 
No, you should keep the latest standalone TittyMagic var package installed. You can then use the AutoUpgrade.cs script to upgrade from TittyMagic 5 to Naturalis in a given scene. Details on that here: https://everlastervr.github.io/docs/naturalis/v1_0/auto_upgrading/#about-upgrading-from-tittymagic-5

In theory that could've been made to work on scene load automatically, but it's better if it's left to the user. For one thing, the names of triggerable parameters are different in the plugins, so loading Naturalis in place of TittyMagic will break any triggers in the scene that target the plugin's parameters.
Thanks for the quick response and for the excellent plugins
 
First of all, thanks for creating the defacto must-have plugin.

Recently I've been scaling things to 3x along with world scale. It helps manipulating object dense areas in VR a lot. But this crashes VaM when attempting to load Naturalis, and froze the last standalone version of TittyMagic. 2x works though.
Is this a limitation, or a bug?
 
First of all, thanks for creating the defacto must-have plugin.

Recently I've been scaling things to 3x along with world scale. It helps manipulating object dense areas in VR a lot. But this crashes VaM when attempting to load Naturalis, and froze the last standalone version of TittyMagic. 2x works though.
Is this a limitation, or a bug?
I would say both a limitation and a bug. World scale is not taken into account anywhere in the plugin's calculations (such as breast volume). Person atom scale is also not fully supported - small deviations are fine but hard collider sizes will go out of whack with atom scale that isn't close to 1.000.

This is something I'll definitely fix in a future version! I'll look into whether the crash would be easy to avoid and put that fix into v1.1, but proper support for nonstandard world scale and atom scale will have to wait for 1.2+.
 
Can you PLEASE, PLEASE release the cinematic trailer as a scene?
;) That's not in my current plans. The trailer was shot in a bunch of different versions of the scene each with their own edits to the animations, there's no single existing scene that contains everything shown in the trailer. Besides that, it would require a ton of work to make it playable
 
I was going to post this on the collider plugin page by Acid Bubbles but this problem only happened when you added colliders to your plugin a long time ago. Only reason I didnt report this issue back then is because I would just ignore it but now its making my characters explode so here I am xD
The colldiers for the glutes seems to be alternating between the values in ColliderEditor and in BootyMagic which results in a small explosion of sorts with the glutes and with the recent updates its making my characters explode after a while. I was thinking that an easy fix would perhaps be an option to disable editing colliders in your plugin but hopefully you can fix this issue tho it would seem im only the one experiencing this?
Also forgot to mention that I didnt touch the values in either plugin.
 
I turned on "disable glute softbody sim" in Givemefps plugin, will this be conflict with naturalis's butt physics?
 
@ForKiKL Not sure what's going on, I'll test that. Naturalis doesn't update the colliders continuously, only during calibration or when you edit their properties. Sorry for the late reply!

@tdktwan Should work fine. Naturalis detects if soft physics was toggled off outside of the plugin and puts calibration to pending, so just calibrate after toggling it via GiveMeFPS.
 
Hi Everlaster! This new plugin is fantastic!

I have been having some issues with your new calibrate mechanic. It moves the character to another place in the scene to do the calibration instead of leaving where they are, and leaves person collision enabled. What this means is that if you happen to have something solid and complex right in the position that Naturalis wants to do its calibrations, you are guaranteed to get a physics explosion as the person tried to inhabit the same space as a solid object. Even if its just like a chair and the legs are colliding with the chair can cause the scene to freak the hell out.

Is there a way to disable this move on calibrate mechanic, or make it turn collisions off when it does the calibration?
 
@VRAdultFun Collision is already disabled during calibration. Can you check if you have another plugin that is forcing collision to be enabled? E.g. test in the default scene. If it still doesn't work, there might be some error in the VAM output log file (C:/Users/<user>/AppData/LocalLow/MeshedVR/VaM/output_log.txt)

The person atom root node doesn't move on calibration, it just loads the calibration pose which has the root node at the feet. So the other control nodes get placed relative to the root node when the calibration pose is loaded.
 
@everlaster Hello! Thanks for the amazing plugins as always!
I am wondering if anyone has a simular issue with the breasts freaking out as in the video below. I just have some expressions playing in timeline, and synergy body movement. Seems to happen when I play the Expressions in timeline.
 
@bill_prime Hi, does it still happen if you disable Synergy?

Please check that the morphs you're animating do not contain any bone morphs. You can tell by checking the female morphs tab, red cog symbol indicates if the morph contains bone morphs.
 
It does happen if Synergy is off as well.
A few of the animated morphs have bone morphs, is that causing an issue with the calibration or something?
 
I love this plugin, and it goes in all of my plugin presets!

However, I wish it didn't freak out if you go to browse the hub for a while with it enabled. If I leave for just a couple seconds it's not bad... but if I spend a decent amount of time searching the hub (like several minutes for a new clothing item or something), then when I return to the scene the character just explodes. Here's a short clip of me navigating to the hub for a few seconds, and again for several. You can see that the second movement is a bit stronger. The longer you are away, the worse it is. 100% guaranteed physics explosion after a while.


Kinda feels like it's constantly generating small, normally imperceptible impulses... but they accumulate over time when the scene is not active, and they all get released at once when you return from the hub browser.

So far the only thing I've found that gets around it is disabling the naturalist booty/tittymagic plugins manually via the plugin list before navigating away to search the hub, then re-enabling and recalibrating when I return. At least it won't explode the character that way. Disabling physics or pausing motion or whatever doesn't do a thing to stop this.

If I only disable bootmagic, then only the chest does the movement when I return, and vice versa. So I'm pretty sure it's something to do with the plugins themselves, and I can repeat this test every time, even with no scene or session plugins loaded, and only the naturalis plugin set on the character atom.
 
@VRAdultFun Collision is already disabled during calibration. Can you check if you have another plugin that is forcing collision to be enabled? E.g. test in the default scene. If it still doesn't work, there might be some error in the VAM output log file (C:/Users/<user>/AppData/LocalLow/MeshedVR/VaM/output_log.txt)

The person atom root node doesn't move on calibration, it just loads the calibration pose which has the root node at the feet. So the other control nodes get placed relative to the root node when the calibration pose is loaded.

OK it turns out it wasn't actually the possible collision. Despite being collision disabled, if the position of the person during calibration just happens to intersect with the the body/head of another person, that person will get displaced slightly by the calibrating person, so something is colliding even with collision off.

However as I said I don't believe that was what is actually causing my physics explosions. I have now had this happen about 5 times on me. I load up a scene I have with Naturalis already in it and configured. Most of the time this scene opens just fine (this is not limited to one scene in particular), however sometimes when it does the initial calibration on scene load the breasts freak the hell out.

Normally the calibrator points the breasts out, up, left, right, back or something like that, and both breasts mirror each others movements. When the physics explosion occurs, this is not what happens during calibration. Instead the breasts fall down (like they have 0 spring) and then start moving independantly of each other, often to one side or another and they shake, this shaking causes a physics explosion. I can control that explosion by going to the person atom and disable soft-body and immediately enabling it again. Sometimes it takes a few goes to stop the explosion. After explosion recovery though the breasts continue to act all funky, and will explode again after a while. When it gets in this situation, the calibration never ends no matter how many times I fix the explosion.

The only way to fix it when this happens is to hard reset and reload the scene
 
It does happen if Synergy is off as well.
A few of the animated morphs have bone morphs, is that causing an issue with the calibration or something?
Not with the calibration, but animating bone morphs can cause the issues shown in the video where breasts jump like that. Solution - just don't animate bone morphs, period.
 
I love this plugin, and it goes in all of my plugin presets!
Thanks!

However, I wish it didn't freak out if you go to browse the hub for a while with it enabled. If I leave for just a couple seconds it's not bad... but if I spend a decent amount of time searching the hub (like several minutes for a new clothing item or something), then when I return to the scene the character just explodes.
I'll see what I can do about that - will add the fix to Naturalis v1.1 beta
 
;) That's not in my current plans. The trailer was shot in a bunch of different versions of the scene each with their own edits to the animations, there's no single existing scene that contains everything shown in the trailer. Besides that, it would require a ton of work to make it playable

Yeah i get it, heck even just a straight camera playthrough would be great but that scene looks amazing!
 
Hello, for some reason the right glute collider got bigger than the left one and both were pushed outwards from the glute area - creating unrealistic gap between her glutes and clothing with sim.

I did adjusted couple of glute, thigh and hips morphs on that model, but that shouldn't really do that. no?

What seemed to help was to "Reset Pose" but that did not last long and with the next scene load the colliders started to "glitch" again.

Would you know how could I fix that permanently please?
 
@shidyhartha Hi, something you can try is go to the Hard Colliders tab in BootyMagic and adjust the collider positions until it looks good. I'm not sure if that will fix things permanently for you, as I'm not really familiar with the issue you're describing. Without seeing a video or reproducing the issue in a scene on my installation, it's pretty hard to know what's actually going on and how to fix it. If you can share a scene with me I can take a look! E.g. host somewhere and send the link via direct message, or send the file directly to me in Discord.
 
@shidyhartha Hi, something you can try is go to the Hard Colliders tab in BootyMagic and adjust the collider positions until it looks good. I'm not sure if that will fix things permanently for you, as I'm not really familiar with the issue you're describing. Without seeing a video or reproducing the issue in a scene on my installation, it's pretty hard to know what's actually going on and how to fix it. If you can share a scene with me I can take a look! E.g. host somewhere and send the link via direct message, or send the file directly to me in Discord.

Okay, thanks I'll send you the scene.

I've tried adjusting the colliders even before writing you here, but there I encountered that the right glute collider was always slightly bigger than the left one. (The option there is either Left glute or Both glutes - maybe cause im on the free version?)

But yes, adjusting the colliders there somewhat fixed the issue, since it is colliders who cause that.
 
Back
Top Bottom