• Hello Guest!

    We have recently updated our Site Policies regarding the use of Non Commercial content within Paid Content posts. Please read the new policy here.

    An offical announcement about this new policy can be read on our Discord.

    ~The VaMHub Moderation Team
  • Hello Guest!

    VaMHuB! Has been updated!

    Please see this thread for more information.

Question Getting an error loading specific scene


Active member
So a couple of days ago I threw together a scene that had quite a bit of timeline animations, effects, etc. Now all of a sudden I can't load this specific scene. I get this error code:

!> Exception during load System.OutOfMemoryException: Out of memory
at (wrapper managed-to-native) string:InternalAllocateStr (int)
at System.Text.StringBuilder.InternalEnsureCapacity (Int32 size) [0x00000] in <filename unknown>:0
at System.Text.StringBuilder.Append (System.Char[] value, Int32 startIndex, Int32 charCount) [0x00000] in <filename unknown>:0
at System.IO.StreamReader.ReadToEnd () [0x00000] in <filename unknown>:0
at MVR.FileManagement.FileEntryStreamReader.ReadToEnd () [0x00000] in <filename unknown>:0
at SuperController.LoadInternal (System.String saveName, Boolean loadMerge, Boolean editMode) [0x00000] in <filename unknown>:0

I've tested plenty of other scenes that I've either made myself or downloaded from the hub and they all work fine still. Does anyone know why this may be happening? Is this specific scene just corrupted now or something? I verified core files and all that and everything else seems to be fine. Any insight would be greatly appreciated!
From the error message, it seems you don't have the memory to run this scene.

Things you could try:
-close all other apps before running Vam.
-make sure your windows virtual memory is set to "managed by windows" and that your hard drive isn't full.
-before loading the scene, go to user preferences > performance 2 and click "trigger memory optimization now". That screen can also show you just how much memory is in use.

If none of this works, you're going to need to remove some of the content from your scene. Since you can't open it, I'd suggest moving some of the vars/resources it depends on so they don't load when the scene opens. Then remove some of the content and resave.
Upvote 0
Tried these all and still no luck unfortunately. I have 32 gigs of ram so I feel like that's plenty but maybe I'm wrong. Interestingly I just remade the entire scene from scratch attempting to keep it as light as possible. I saved 5 or 6 times throughout at different stages of recreating it too for testing. I finished it and everything was running fine but once I went to reload the scene no luck. I even saved the core part as a subscene just in case. Loading the subscene doesn't work either.

The scene only has 2 person atoms, 6 or so ui buttons, a few lights, and a rhythm audio player.

The only thing I can think of is maybe it's the timeline animations I have on one of the atoms? I imported three different animations from other scenes that I threw together into one timeline in separate animation sequences. Each animation is 150 - 250 seconds in length with lots of keyframes. Could that be a factor?
Upvote 0
You can share the scene here and I can try to open it.
How large is the JSON? There's a limit of 500 MB.

Ah that must explain it. Looking at my files, of all the tests I've conducted it seems the ones that wouldn't load are all just above that 500 MB limit. It definitely seems to be the timeline animations that are taking up so much space. I converted a couple of mocaps I downloaded to timeline and they've got some 7,000 keyframes a piece so. I'll probably just try using a subscene for each one instead and see if that works better. Thanks so much for the help!
Upvote 0
Just had this issue. I want to mention, if you had worked a lot on the scene (not the animation) and don't want to lose your progress:

You can navigate to the Json file in Vam/Saves/scene, open it with Notepad and delete simply delete 90% of the "t" "v" "c" "i" "o" lines under "Controllers" (it will be massive list, hence the size, so use something like "start selection & end selection").

Then start VaM and load the scene. The mocap animation will now be missing most keyframes, just import it again and this time use "reduce keyframes" in Timeline.
Upvote 0
Top Bottom